Users intermittently unable to load the platform or log in.
Incident Report for Propeller
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 22:21 UTC
Update
A stable fix has been implemented and the systems have recovered. Our team is continuing to monitor over the next few hours.
Posted Feb 28, 2024 - 22:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2024 - 22:10 UTC
Investigating
We are re-experiencing the earlier issues and receiving further reports of performance instability - our engineers are investigating now.
Posted Feb 28, 2024 - 22:00 UTC
Monitoring
We are experiencing reports that users are unable to load the platform or log in. We have identified the issue and rolled out a fix and the platform is returning to normal performance. We will continue to monitor over the next couple of hours.
Posted Feb 28, 2024 - 21:06 UTC
This incident affected: Propeller Portal, Data Processing, AeroPoints, Propeller Mobile, and DirtMate.